Commit 25eb7e2b authored by erwan's avatar erwan
Browse files

Lutin requires ocaml 4.02 because of the Byte module.

also, add -I/usr/local/include/ in CCOpt oasis rules for packages
that depend on gmp, as darwin can not find headers in this dir
(bouh).  There is probably a better way to turn arouns that, but...
parent 1af0fb62
OASISFormat: 0.4
Name: Lutin
Version: 2.25
Version: 2.26
Authors: Erwan Jahier
Maintainers: erwan.jahier@imag.fr
License: PROP
Plugins: DevFiles (0.4), META (0.4)
Synopsis: Lutin: modeling stochastic reactive systems.
Homepage: http://www-verimag.imag.fr/Lutin.html
OCamlVersion: >= 4.01
OCamlVersion: >= 4.02
Description:
Lutin is a language to model stochastic reactive systems.
It has been initially designed to model environments and perform
......@@ -56,7 +56,7 @@ Library "lutin-utils"
Modules: LutinUtils
Install: true
CSources: lutinUtils.h,lutinUtils_c.c,lutinUtils_stubs.c
CCOpt: -fPIC -I$pkg_camlidl
CCOpt: -fPIC -I$pkg_camlidl -I/usr/local/include/
Executable lurettetop_exe
Path: ltop/src
......@@ -102,7 +102,7 @@ Library polka
polka_c.c, internal.c, bit.c, satmat.c, cherni.c,
vector_c.c, matrix_c.c, poly_c.c,
vector_caml.c, matrix_caml.c, poly_caml.c, polka_caml.c
CCOpt: -O3 -fPIC -DPOLKA_NUM=3 -I$pkg_camlidl
CCOpt: -O3 -fPIC -DPOLKA_NUM=3 -I$pkg_camlidl -I/usr/local/include/
DllLib: libgmp.so dllcamlidl.so
......
let str="2.25"
let sha="6fa99f9"
let str="2.26"
let sha="1af0fb6"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment