Commit d23dc77e authored by paugier's avatar paugier
Browse files

requirements.txt with conda in root directory

parent a4f6a480
......@@ -169,7 +169,7 @@ Please tell us before the training if it does not work.
#### Install few packages in your base conda environment
```
conda install ipython spyder jupyter numpy scipy pandas matplotlib
conda install --file requirements.txt
```
#### Check your environment
......
## Timing:
We use [invoke](https://www.pyinvoke.org/) (`pip install invoke`) to build and run the benchmarks. The full requirements can be installed with `pip install -r requirements.txt`.
We use [invoke](https://www.pyinvoke.org/) to build and run the benchmarks.
See [how to get autocompletion with invoke](http://docs.pyinvoke.org/en/1.2/invoke.html?highlight=completion#cmdoption-print-completion-script).
......
astunparse==1.6.2
beniget==0.1.0
cffi==1.12.3
Cython==0.29.10
decorator==4.4.0
docutils-stubs==0.0.10
-e git+https://gricad-gitlab.univ-grenoble-alpes.fr/python-uga/training-hpc.git@fa9d7e7c22b54d54cd17890c58f01821e9b3d321#egg=dtw_cort_dist_mat&subdirectory=pyfiles/dtw_cort_dist/V2_c_dtw
gast==0.2.2
invoke==1.2.0
llvmlite==0.29.0
mpi4py==3.0.1
networkx==2.3
numba==0.44.0
numpy==1.16.4
parsimonious==0.7.0
pkg-resources==0.0.0
ply==3.11
pycparser==2.19
pythran==0.9.2
six==1.12.0
transonic==0.2.2
# to be used with:
# conda install --file requirements.txt
# utilities
ipython
spyder
jupyter
invoke
# base numerics
numpy
scipy
matplotlib
pandas
h5py
# wrapper
cffi
# accelerators
cython
numba
pythran
transonic
# parallel
mpi4py
dask
joblib
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment