Commit 219f0ce8 authored by Hannu Nyman's avatar Hannu Nyman
Browse files

luci(-ssl)-nginx: depend on luci-app-opkg

Commit 391e82d6

 in 2018 added luci-app-opkg dependency to
the 'luci' collection and its derivatives, but as nginx collections
do not depend on main 'luci', they did not get the intended change.

Fixes #4148
Signed-off-by: default avatarHannu Nyman <hannu.nyman@iki.fi>
parent 16f443bf
......@@ -13,7 +13,7 @@ LUCI_TITLE:=LuCI interface with Nginx as Webserver
LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
LUCI_DEPENDS:= \
+nginx +nginx-mod-luci +luci-mod-admin-full +luci-theme-bootstrap \
+luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+luci-app-firewall +luci-app-opkg +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+rpcd-mod-rrdns
PKG_LICENSE:=Apache-2.0
......
......@@ -15,7 +15,7 @@ LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
LUCI_DEPENDS:= \
+nginx-ssl +nginx-mod-luci-ssl +luci-mod-admin-full +luci-theme-bootstrap \
+luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+luci-app-firewall +luci-app-opkg +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+rpcd-mod-rrdns +openssl-util
PKG_LICENSE:=Apache-2.0
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment