Vous avez reçu un message "Your GitLab account has been locked ..." ? Pas d'inquiétude : lisez cet article https://docs.gricad-pages.univ-grenoble-alpes.fr/help/unlock/

Commit 32de1dd3 authored by Marc Coiffier's avatar Marc Coiffier
Browse files

Start using Git as a changelog-tracking system, too (why not ?)

A new script, naively named 'changelog', can now use the information
from release tags and commit notes to produce a full changelog for any
package.

A commit message can be added to a changelog by adding a note
containing the word 'changelog-<packageName>'.
parent 92042b21
......@@ -28,3 +28,8 @@ doc: build
install: STACK_FLAGS += --copy-bins
install: build
FORCE:
%/ChangeLog.md: FORCE
scripts/changelog $* > $@
# Revision history for misc
Revision history for capricon
===============
## 0.1.0.0 -- YYYY-mm-dd
### release-capricon-0.13.1 / package-capricon-0.13.1
* First version. Released on an unsuspecting world.
- Implement a new kind of "quiet" mustache in CaPriCon, to allow precise formatting commands to be inserted into a document
### release-capricon-0.13 / package-capricon-0.13
- Upend the CaPriCon rendering pipeline, to allow for multiple output backends (for now, HTML and LaTeX)
### release-capricon-0.12.3 / package-capricon-0.12.3
- Correct the behavior `type_of` function, causing it to fail on ill-typed terms instead of falsely succeeding
### release-capricon-0.12.2.1 / package-capricon-0.12.2.1
- Make CaPriCon preserve whitespace at the end of documents
### release-capricon-0.12.2 / package-capricon-0.12.2
- Update the CaPriCon HTML scaffold to fit the new stylesheet
### release-capricon-0.12.1 / package-capricon-0.12.1
- Introduce a new 'set-stack' builtin, to go with the new backquote features
- Annotate matching braces with text spans when generating CaPriCon paragraphs, to allow better syntax highlighting to take place
- Output quoted characters as-is when generating Markdown from CaPriCon, to preserve the correct newline count
- Make the order of evaluation left-to-right at all backquote depths in concatenative languages.
### release-capricon-0.12 / package-capricon-0.12
- Add support for writing custom examples after CaPriCon code blocks, to make the resulting pages more easily explorable
- Make better backquotes for CaPriCon
### release-capricon-0.11
- Change WiQEE.hs to be used as a Web Worker instead of running in the application thread
- Release CaPriCon 0.11, now with a working module system
### package-capricon-0.11
- Start offering basic SVG generation of formulae with the %g format in CaPriCon
- Adjust CaPriCon output to allow syntax highlighting to take place in code blocks
- Notify the user of changes in the console's state when it becomes active (in WiQEE)
- Define a 'cons' builtin for CaPriCon (and other concatenative languages)
- Remove the 'module' builtin in favor of the more flexible 'redirect' / 'set-vocabulary' combination
-XRebindableSyntax
-XFlexibleInstances
-XMultiParamTypeClasses
-XFlexibleContexts
-XFunctionalDependencies
-XTypeOperators
-XTupleSections
-XImplicitParams
-XGeneralizedNewtypeDeriving
-XRankNTypes
-W
-O4
This diff is collapsed.
../LICENSE
\ No newline at end of file
-XRebindableSyntax
-XNoMonomorphismRestriction
-XTypeOperators
-XViewPatterns
-XFlexibleInstances
-XFlexibleContexts
-XMultiParamTypeClasses
-XFunctionalDependencies
-XTupleSections
-XRankNTypes
-XExistentialQuantification
-XGeneralizedNewtypeDeriving
-XRecursiveDo
-XImplicitParams
-O4
......@@ -12,7 +12,7 @@ maintainer: marc.coiffier@univ-grenoble-alpes.fr
-- copyright:
category: Language
build-type: Simple
extra-source-files: CHANGELOG.md
extra-source-files: ChangeLog.md
cabal-version: >=1.10
executable curly-gui
......
# Revision history for curly
Revision history for curly
===============
## 0.1.0.0 -- YYYY-mm-dd
### release-curly-0.59.5 / package-curly-0.59.5
* First version. Released on an unsuspecting world.
- Integrate the 'curly-gui' and 'definitive-graphics' packages from old projects
- Update the repository URLs in the Curly documentation; update the install script to allow installing Bash completions in a standard location
- Start defining two new builtins, 'showExpr' and 'showSyntax', to help when debugging the behaviour of macros
### release-curly-0.59.4.5 / package-curly-0.59.4.5
- Change the default Curly locations to follow the XDG specification when possible
- Correct a small parser bug that caused some interactive commands to need two newlines instead of one
- Integrate the 'bashcomps.shl' library into the Curly package, so that unprivileged users can still benefit from great completions
### release-curly-0.59.4.4 / release-curly-0.59.4.3 / package-curly-0.59.4.3
- Change the default Curly locations to follow the XDG specification when possible
- Correct a small parser bug that caused some interactive commands to need two newlines instead of one
http://coiffier.net/projects/definitive-framework.html
This diff is collapsed.
../LICENSE
\ No newline at end of file
-W -O4
-I/usr/include/gtk-3.0
-I/usr/include/at-spi2-atk/2.0
-I/usr/include/at-spi-2.0
-I/usr/include/dbus-1.0
-I/usr/lib/dbus-1.0/include
-I/usr/include/gtk-3.0
-I/usr/include/gio-unix-2.0/
-I/usr/include/cairo
-I/usr/include/pango-1.0
-I/usr/include/atk-1.0
-I/usr/include/cairo
-I/usr/include/pixman-1
-I/usr/include/freetype2
-I/usr/include/libpng16
-I/usr/include/harfbuzz
-I/usr/include/freetype2
-I/usr/include/harfbuzz
-I/usr/include/libdrm
-I/usr/include/libpng16
-I/usr/include/gdk-pixbuf-2.0
-I/usr/include/libpng16
-I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include
-threaded
-XRebindableSyntax
-XNoMonomorphismRestriction
-XTypeOperators
-XViewPatterns
-XFlexibleInstances
-XFlexibleContexts
-XMultiParamTypeClasses
-XFunctionalDependencies
-XTupleSections
-XRankNTypes
-XExistentialQuantification
-XGeneralizedNewtypeDeriving
-XRecursiveDo
-XImplicitParams
-pgmP cpp
A definitive package allowing you to open windows, read image files and render text
......@@ -12,7 +12,7 @@ maintainer: marc.coiffier@univ-grenoble-alpes.fr
-- copyright:
category: Graphics
build-type: Simple
extra-source-files: CHANGELOG.md
extra-source-files: ChangeLog.md
cabal-version: >=1.10
library
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment