Commit e87f2457 authored by Xavier Leroy's avatar Xavier Leroy
Browse files

Support Coq 8.12.1

parent dc270187
......@@ -35,7 +35,7 @@ The clightgen tool:
logical assertions, which was never used and possibly confusing.
Coq and OCaml development:
- Compatibility with Coq 8.12.0, 8.11.2, 8.11.1.
- Compatibility with Coq 8.12.1, 8.12.0, 8.11.2, 8.11.1.
- Can use already-installed Flocq and MenhirLib libraries instead of their
local copies (options `-use-external-Flocq` and `-use-external-MenhirLib`
to the `configure` script).
......
......@@ -527,14 +527,14 @@ missingtools=false
echo "Testing Coq... " | tr -d '\n'
coq_ver=$(${COQBIN}coqc -v 2>/dev/null | sed -n -e 's/The Coq Proof Assistant, version \([^ ]*\).*$/\1/p')
case "$coq_ver" in
8.8.0|8.8.1|8.8.2|8.9.0|8.9.1|8.10.0|8.10.1|8.10.2|8.11.0|8.11.1|8.11.2|8.12.0)
8.8.0|8.8.1|8.8.2|8.9.0|8.9.1|8.10.0|8.10.1|8.10.2|8.11.0|8.11.1|8.11.2|8.12.0|8.12.1)
echo "version $coq_ver -- good!";;
?*)
echo "version $coq_ver -- UNSUPPORTED"
if $ignore_coq_version; then
echo "Warning: this version of Coq is unsupported, proceed at your own risks."
else
echo "Error: CompCert requires a version of Coq between 8.8.0 and 8.12.0"
echo "Error: CompCert requires a version of Coq between 8.8.0 and 8.12.1"
missingtools=true
fi;;
"")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment