Commit b0fa0fde authored by Anton Gladky's avatar Anton Gladky
Browse files

Make Yade compatible with VTK7.

Thanks to Luc OGER <luc.oger@univ-rennes1.fr>
https://bugs.launchpad.net/yade/+bug/1586275
parent 86aa1642
......@@ -502,13 +502,13 @@ SET_TARGET_PROPERTIES(yade PROPERTIES LINK_FLAGS "-Wl,--as-needed" )
TARGET_LINK_LIBRARIES(boot yade)
IF(ENABLE_VTK)
IF(${VTK_MAJOR_VERSION} EQUAL 6)
IF(${VTK_MAJOR_VERSION} GREATER 5)
TARGET_LINK_LIBRARIES(yade ${VTK_LIBRARIES})
ADD_DEFINITIONS("-DYADE_VTK6")
MESSAGE(STATUS "VTK version 6 is found")
ELSE(${VTK_MAJOR_VERSION} EQUAL 6)
MESSAGE(STATUS "VTK version >5 is found")
ELSE(${VTK_MAJOR_VERSION} GREATER 5)
TARGET_LINK_LIBRARIES(yade vtkHybrid)
ENDIF(${VTK_MAJOR_VERSION} EQUAL 6)
ENDIF(${VTK_MAJOR_VERSION} GREATER 5)
ENDIF(ENABLE_VTK)
IF(ENABLE_GUI)
TARGET_LINK_LIBRARIES(yade _GLViewer ${GUI_LIBS})
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment