Commit 12d5c389 authored by Millian Poquet's avatar Millian Poquet
Browse files

Travis: move boost 1.58+ problems to master branch

Some kind of Travis bruteforcing was done in data_storage,
but it should be in master since boost 1.58+ is only needed
for batexec, which is only in the master branch at the moment.
parent 895daa4c
......@@ -3,8 +3,6 @@ addons:
apt:
packages:
- cmake
- libboost-dev
- libboost-all-dev
- doxygen
- graphviz
- python-pip
......@@ -32,6 +30,23 @@ before_install:
- cp travisci_rsa ~/.ssh/id_rsa
- ssh-keyscan scm.gforge.inria.fr >> ~/.ssh/known_hosts
# Update apt lists (in order to install boost 1.58+)
- cat /etc/apt/sources.list
- cp /etc/apt/sources.list /tmp/sources.list
- echo 'deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse' >> /tmp/sources.list
- echo 'deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse' >> /tmp/sources.list
- sudo mv /tmp/sources.list /etc/apt/sources.list
# Install boost 1.58+ (does not work, to fix!)
- mkdir -p /tmp/boost
- cd /tmp/boost
- sudo apt-get update
- sudo apt-get build-dep libboost-all-dev
- sudo apt-get -b source -t xenial libboost-all-dev
- sudo ls -l .
- sudo dpkg --force-all -i *.deb
- sudo find / -name 'libboost*.so*'
install:
# Install SimGrid
- cd ${BATSIM_BASE_DIR}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment