Commit e8ac807b authored by Emmanuel Promayon's avatar Emmanuel Promayon
Browse files

FIXED disabling test that won't pass on VTK7 due to VTK version written in files

parent c9641eb9
......@@ -14,12 +14,14 @@ set(SHIBOKEN_CAMITK_SDK_PATH ${SHIBOKEN_CAMITK_SDK_PATH}:${CMAKE_CURRENT_SOURCE_
# --- Specific test management ---
# --------------------------------
if("${VTK_VERSION}" VERSION_LESS 6.3)
if(NOT "${VTK_VERSION}" VERSION_EQUAL 6.3)
message(WARNING "Disabling test action-reconstruction-integration-test\n"
"Reason: VTK version is less than 6.3\n"
"VTK6.2 has a bug when it saves vtk files: it does not save the proper VTK file format version\n"
"On Ubuntu 16.04 LTS, the default VTK version is 6.2 not 6.3.\n"
"Ubuntu 16.04 LTS is supported but these test will fail if not disabled\n")
"Ubuntu 16.04 LTS is supported but these tests will fail if not disabled\n"
"On debian buster, the default VTK version is 7.1 not 6.3\n"
"Debian buster is supported but these tests will fail if not disabled\n")
set_tests_properties(action-reconstruction-integration-test PROPERTIES DISABLED true)
endif()
......
......@@ -21,12 +21,14 @@ set(SHIBOKEN_CAMITK_SDK_PATH ${SHIBOKEN_CAMITK_SDK_PATH}:${CMAKE_CURRENT_SOURCE_
# --- Specific test management ---
# --------------------------------
if("${VTK_VERSION}" VERSION_LESS 6.3)
if(NOT "${VTK_VERSION}" VERSION_EQUAL 6.3)
message(WARNING "Disabling test component-vtkmesh-level3-1 to component-vtkmesh-level3-16\n"
"Reason: VTK version is less than 6.3\n"
"VTK6.2 has a bug when it saves vtk files: it does not save the proper VTK file format version\n"
"On Ubuntu 16.04 LTS, the default VTK version is 6.2 not 6.3.\n"
"Ubuntu 16.04 LTS is supported but these test will fail if not disabled\n")
"Ubuntu 16.04 LTS is supported but these tests will fail if not disabled\n"
"On debian buster, the default VTK version is 7.1 not 6.3\n"
"Debian buster is supported but these tests will fail if not disabled\n")
set_tests_properties(component-vtkmesh-level3-1
component-vtkmesh-level3-2
component-vtkmesh-level3-3
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment