Commit 8581add5 authored by saubatn's avatar saubatn
Browse files

DELETE : Release build type

NEW : Qt dependency.

git-svn-id: svn+ssh://scm.forge.imag.fr/var/lib/gforge/chroot/scmrepos/svn/camitk/trunk/camitk@150 ec899d31-69d1-42ba-9299-647d76f65fb3
parent 169c2f56
......@@ -126,9 +126,6 @@ if (UNIX AND NOT WIN32)
set(CPACK_PACKAGE_DEFAULT_LOCATION "/usr")
set(CPACK_SET_DESTDIR TRUE)
# Set build type by default as release
set(CMAKE_BUILD_TYPE "Release")
# Package information
set(CPACK_PACKAGE_DESCRIPTION_SUMMARY ${CPACK_PACKAGE_DESCRIPTION_SUMMARY})
set(CPACK_DEBIAN_PACKAGE_DESCRIPTION ${CPACK_PACKAGE_DESCRIPTION})
......@@ -139,11 +136,11 @@ if (UNIX AND NOT WIN32)
# Dependencies depending on the Operating System.
# Ubuntu
if("${LSB_DISTRIB}" MATCHES "Ubuntu11.10")
set(CPACK_DEBIAN_PACKAGE_DEPENDS "libinsighttoolkit3.20, libxml2, libvtk5.6-qt4 ")
set(CPACK_DEBIAN_PACKAGE_DEPENDS "libqt4-dev libinsighttoolkit3.20, libxml2, libvtk5.6-qt4 ")
endif("${LSB_DISTRIB}" MATCHES "Ubuntu11.10")
# For Ubuntu11.04
if("${LSB_DISTRIB}" MATCHES "Ubuntu12.04")
set(CPACK_DEBIAN_PACKAGE_DEPENDS "libinsighttoolkit3.20, libxml2, libvtk5.8-qt4 ")
set(CPACK_DEBIAN_PACKAGE_DEPENDS "libqt4-dev libinsighttoolkit3.20, libxml2, libvtk5.8-qt4 ")
endif("${LSB_DISTRIB}" MATCHES "Ubuntu12.04")
# Debian
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment