Vous avez reçu un message "Your GitLab account has been locked ..." ? Pas d'inquiétude : lisez cet article https://docs.gricad-pages.univ-grenoble-alpes.fr/help/unlock/

Commit 7f9a3de2 authored by Emmanuel Promayon's avatar Emmanuel Promayon
Browse files

FIXED get xsd version properly + include path for xsd

For some reason, on Win7 (or maybe for xsd 3.3.0), the --version argument
output goes to stderr not stdout
parent 06910b07
......@@ -10,8 +10,7 @@
# XSD_CXX_STD_FLAG force to C++11 if and only if xsd version is greater or equals to 4.0.0, empty string otherwise
find_path(XSD_INCLUDE_DIR
NAMES elements.hxx
PATH_SUFFIXES xsd/cxx/parser
NAMES "xsd/cxx/parser/elements.hxx"
PATHS "[HKEY_CURRENT_USER\\software\\xsd\\include]"
"[HKEY_CURRENT_USER]\\xsd\\include]"
$ENV{XSDDIR}/include
......@@ -46,6 +45,7 @@ if(XSD_FOUND)
unset(XSD_VERSION_TEXT)
execute_process(COMMAND ${XSD_EXECUTABLE} --version
OUTPUT_VARIABLE XSD_VERSION_TEXT
ERROR_VARIABLE XSD_VERSION_TEXT
OUTPUT_STRIP_TRAILING_WHITESPACE
)
# extract xsd version number
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment